Dante Domain Manager v1.9.2.26645

Release Date: 22nd of September 2026

Dante Domain Manager (DDM) 1.9.2 delivers DeviceLink enhancements, fixes for several customer issues, and important security patches.

Note: As of DDM 1.9, pre-v4.x firmware [legacy] devices are no longer supported.

DDM 1.9.x is provided on a Rocky 9 platform.

Existing DDM customers can update from the DDM UI (Settings) for the smoothest experience.

For the majority of new customers, we recommend installing the self-contained ISO on Hyper-V, ESXi, Proxmox, or bare metal.

The hypervisor or bare metal hardware must support AVX instructions.


Important: DDM installations at version 1.5 or earlier cannot be updated to v1.8 via the online update feature in the DDM user interface. For installation instructions, please see Upgrading DDM from v1.5.x or Earlier – Installation Guide.

See the DDM user guide for more information about DDM features.

See the Managed API User Guide for more information about the API.

If you require root access to the OS, you can use the scripted install. Our support team can help advise on this.

Hosting of Dante Domain Manager in AWS was introduced in DDM v1.7.x.

See the Deployment Guide for AWS for more information about AWS hosting and scripted installs of DDM.


Installation file – Installer script

The DDM ISO Installer script can be run on your pre-existing Rocky 9 Linux system to install the application. The DDM Installer script is suitable for installation on selected cloud hosts.

URL for direct download (use curl -O <url>):

https://audinate-software-updates.sgp1.cdn.digitaloceanspaces.com/DDM/1/1.9/1.9.2/ddm-1.9.2.26645_linux_x64.sh

SHA-256 hash:

085f99422101cd393642e26d9e217d2c21f4f6a895fc8121f01138a2a709acb4

ZIP File

File download: ddm-1.9.2.26645_linux_x64.sh.zip

File size: 323 MB

SHA-256 hash:

d381fbbbe24dbf30df9b790d2da2ae7880cdcf52cad734963f3e63e9a72a396d

New features since v1.9.1

  • N/A (maintenance release)
  • DAU-1137: When an IP address is used instead of a fully qualified domain name (FQDN), Device Link does not recognize the device
    • This affects Device Link functionality; devices could not connect to the Argo Server in DDM.
  • DAU-1101: All DL/GraphQL errors are generic INTERNAL_SERVER_ERROR (Failed to set device parameters)
    • Users did not get useful error details and must guess what went wrong with the GraphQL request.
  • ETS-6956: Update MongoDB version to 7.0.40
    • Security fixes
  • ETS-6880: json load buffer error: 7 in snmp.log
    • When querying an SNMP entity for a tree of information, DDM returned incorrect or non-real-time values.
  • DDM-1156: Check that redundant nodes are licensed before creating an HA cluster
    • DDM allowed creating an HA cluster when the redundant node is not licensed, permitting invalid or unsupported cluster setups.
  • ETS-6870: Controller unable to authenticate to DDM 1.9
    • LDAP users with default permission “None” experienced permission check failures and device manager crashes. Recommend setting default roles to read-only as a workaround.
  • ETS-6901: The reported package count for updates did not match the number actually updated
    • Customers could not determine which packages updated. DDM adds a package update log to capture details.
  • ETS-6875: LDAP Groups Privileges edit caused a ‘Match Failed’ error
    • Editing LDAP group Domain-Specific Privileges after deleting and recreating a domain triggered a “Match Failed” error in the web UI.
  • DDM-1166: Domain rendering on the dashboard was slow with 1,000 domains
    • DDM 1.9 dashboard returns 429 errors when handling many domains and devices due to rate limiting.
  • ETS-6939: Inconsistencies between DDM audit log and email notification

New known issues

  • N/A

Pre-existing known issues

  • DDM-1114: HA failover can fail if the primary node loses contact with both redundant nodes for less than 60 seconds. Restart the primary node if this occurs.
  • DDM-811: After installation or disbanding a HA cluster the network interface may be disabled. Workaround: Configure the network interface on the appliance menu to be static or dynamic, then reboot the appliance.
  • DDM-430: Selecting a different number of records to show in the audit log fails. The second attempt at selecting a different number of records to show will succeed.
  • DDM-432: The branding feature is available only when the Main node is active. It is not available for the backup (auxiliary) node. The branding feature will be restored once the Main node is again active.
  • DDM-428 / DDM-429: Long API key descriptions may overlap with other page elements. Workaround: Restrict the API key description to approx. 35 characters, inc. spaces.
  • MIL-4635: High latency settings for a device, that are only available with Dante Domain Manager, remain when the device is unenrolled. Workaround: Manually change the latency to one that is better suited for local unmanaged network operation.

Audinate’s Support for Inclusive Language

To our customers: some of the terminology used in Dante products has been changed to align with modern usage. Specifically, areas related to Dante clocking now refer to “Primary Leader Clock”, “Leader Clocks” and “Follower Clocks” to describe the functions of each role more clearly.